Google Play Console’da uygulamalarımdan birini güncellerken en son Api’lere geçilmesi gerektiğini bildiren uyarılar karşıma çıktı.
Şu anda geçerli son Android sürümü android 10 için gerekli API’ler API 29 olarak veriliyor.
Ağustos 2020 itibarı ile Google Play için yayınlayacağınız tüm yeni uygulamalar api 29 ve android 10 sürümünü hedeflemeli denmiş.
Mevcut uygulamalarınızı güncellerken de kasım 2020′ den sonra api 29 hedefi zorunlu olacak.

Ben Resimli Sesli Hikayeler uygulamız içerisine ingilizce opsiyonu ekledim.Uygulamanın android sürümünü güncellemek için yollarken bu uyarı ile karşılaştım.Adobe air sdk HARMAN en son sürümü 33.1.1.217 içerisinde hala hedef android api 28 olarak belirtilmiş.Ben main xml içerisinde buna rağmen hedef api seviyesini 29 yaparak bu sdk ile compile ettim.

EDİT(2 eylül 2020):API 29 için adobe air sdk 33.1.1.217 web sayfası içersinde release notlarında 29 nolu api yi bu sürümün deskteklediği söyleniyor.PDF olarak verilen release notlarında hala 28 nolu api hedef api olarak gözüküyor.
Ben android tarafındaki 10 adet uygulamamı geçen hafta 29 nolu api hedefini ayarlayarak güncelledim…
Güncellemeler kabul edildi.

Şimdilik ekstra bir problem görünmüyor…




Yeni bir blog notunda görüşmek üzere…

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir